Mise à niveau de NextGEN Gallery 1.9.13 vers 2.0.61

Régulièrement je tente une mise à jour de ma galerie photo NextGEN Gallery 1.9.13 vers les versions 2.0.X, mais il semblerait que les auteurs n’aient rien fait pour assurer une compatibilité avec la dernière version 1.9.X et c’est bien dommage. Encore aujourd’hui j’ai tenté une migration vers la dernière version 2.0.61 mais sans succès. Il y a quand même du progrès car cette version trouve bien toutes les galeries et affichent les photos mais j’ai le warning récurent:

Warning: strpos() [function.strpos]: Empty delimiter in /wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/fs/class.fs.php on line 304

qui s’affichent à peu près sur toutes les pages avec quelques erreurs fatales. J’ai bien trouvé ce thread qui parle du sujet mais sans solution dans l’immédiat. Dommage je n’ai jamais été aussi près de passer à une version 2.0.X, les fois précédentes il y avait vraiment rien qui marchait. Fort heureusement on peut revenir à la version 1.9.13 sans difficulté en écrasant tous les fichiers dans le répertoire wp-content/plugins/nextgen-gallery. J’espère quand même que quelque chose sera fait pour les utilisateurs qui sont restés à la version 1.9.13, et je sais qu’on est nombreux, car au gré des upgrades de wordpress, un jour ou l’autre plus rien ne marchera.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée.

Vérification anti robot *